JobRoller 1.7.3

ATTENTION: Not all products listed below may be compatible with JobRoller 1.7.3 as is. However you can always request an older compatible version of any of the products listed below that will work with JobRoller 1.7.3.

ATTENTION: Not all products may work with JobRoller 1.7.3 as is, but any product that does not work will have an older version available by request. If you can’t get any of the below plugins to work with it, please get in touch for an older compatible version.